CGE ENB 5

by chinagreenelvis
Please explain why you're reporting this file:

Cancel
 
• ENBSeries post-processing
• Designed for 1.0.7.0 and EFLC
• Easily modified
• Adjustable static depth of field
• Motion blur
• FXAA anti-aliasing
• Custom visual presets
• Increased draw distance
• Timecycle written from scratch
• Crash-free
• Proper rendering of cutscenes
• No overbrightness/darkness
• Works in multiplayer
• No red skies/no black horizon
• Improved vehicle shadows

This mod is highly customizable. You are encouraged to change the settings to suit your tastes. Custom presets are included!
Rating:
8.17/10 - 29 votes
Downloads: 5,212
Added: October 3, 2012 2:20AM
Last Downloaded: September 22, 2014 12:10AM
File Size: 87 B
» Author Website
» Author Email

Sorry, you must be registered and logged in to add a video to this file. Log in now!

maybe you should gift me a gtx 580 so that i can play with this mod :p anyway fantastic work as per the screens :)
Posted on October 3, 2012 5:47AM by SKS
para mi es mala tiene puntitos de graficos 5/10

Posted on October 3, 2012 8:26PM by DIFASOFTWARE
You just made 4.0 and now we have 5.0?! Is this Christmas? Thanks man! It'd be nice to see screens of each Visual effect or theme, but I'm not complaining. Great screenshots too!

DIFA - arreglar tu enbconfig.ini a ver "float4 NoiseAmount = 0;"?
Posted on October 3, 2012 9:47PM by DLer
Yeah, 4.0 had some major problems with ugly weather transitions. This technically might have been 4.01, but the work I had to do was so extensive that it felt more like a complete overhaul. So now it's version 5 instead, and hopefully the last one I'll ever have to release. I think I'm finally satisfied with it.
Posted on October 4, 2012 1:13AM by chinagreenelvis
@chinagreenelvis, what about fps? CGE ENB 2.0 had great fps, since 3.0 the fps has gone the wrong way... why?
Posted on October 4, 2012 7:49AM by eabettebalterze
Disable DOF or lower the quality. The readme file will tell you how to do this.
Posted on October 4, 2012 1:48PM by chinagreenelvis
Either that or disable the improved vehicle shadows by using the original textures instead?
Posted on October 4, 2012 1:56PM by chinagreenelvis
hmm

not bad..

but guys, there are bunch of great enbmods for 1070 or eflc here

but I don't think this is a great enb

I think 3.0 is better LoL

4/10
Posted on October 5, 2012 6:55PM by kkmiyou
Please, link to some of the other good 1070 ENB mods. Seriously, feel free.
Posted on October 5, 2012 11:56PM by chinagreenelvis
Hmm, some problems on my end with this one.

- Sunny-Windy, Cloudy, Rain and Drizzle weathers are all overly bright at night. The issue seems to be clouds are too bright and opaque at night.

- Day/Night transitions don't seem to be timed right and occur too fast. For instance it should be brighter at 5AM, yet darker at 6AM. It seems like the transition time was cut in half which I wouldn't recommend, besides that the sun takes a good 2 hours to come out RL, the real issue with doing that is that you can't offset it to the 30th minute of an hour and thus the transitions will occur a little earlier or later than they should. I could be wrong about the transition time being cut in half just the impression I got.

For now I've copied 7PM-6AM from 4.0 into the timecyc for these weather types although even the other weathers have the odd transitions.

Besides these issues I found it looked a bit nicer than 4.0, could just be the extra contrast though, as not sure you logged that you changed anything else.
Posted on October 6, 2012 1:48AM by MarkC9
The clouds are the default game values, for the most part. I actually made them darker and more transparent in some cases.

I have literally no control over how fast the sun moves in the game.

I'm done editing the weather cycle. If it seems unrealistic, you're just going to have to live with that. Sorry.
Posted on October 6, 2012 3:35AM by chinagreenelvis
lmfao, dont let these slappers bother you CGE, some ppl will never be happy... thanks again for your continued efforts with the improvement of the mod.

i remember when i first stumbled onto your redsky fix.

Posted on October 6, 2012 6:16AM by kitoxx
Game doesn't start.

What do I have to do with the "Visual Presets" foulder?
Posted on October 6, 2012 8:29AM by DominoCity
DominoCity, make sure you're using a clean install and have the latest versions of dot.net and Games for Windows Live.

The Visual Presets folder is explained in the readme file.

Read the readme file.
Posted on October 6, 2012 9:07AM by chinagreenelvis
@MarkC9, you can always get yourself a copy of EditIV and go to town with it.

http://www.gta4-mods.com/tools/edit-iv-timecyc-editor-for-gtaiv-and-eflc-f16628
Posted on October 6, 2012 4:01PM by chinagreenelvis
I've fiddled with it before but must claim ignorance as to what most functions do. Question:

I'm thinking I'll just take the transition hours from 4.0 (all weathers) as well as the night hours for those mentioned weather types and copy them into 5.0

Is there even a point in that, or should I might as well use the 4.0 timecyc at that point?
Posted on October 6, 2012 4:10PM by MarkC9
Updated to version 5.01 - Fixed problem with phone pictures being black, slight changes to the timecyc file, made DOF disabled by default so people who don't know how to read the readme.txt file will stop complaining about the FPS
Posted on October 6, 2012 5:58PM by chinagreenelvis
@Mark, clouds at night over a city are just generally kind of bright because you get the light reflecting back down from the buildings. I made them a bit darker in the latest version.

The sky is dark at 5 a.m. because there are no incremental periods between 5 and midnight. Otherwise most of the nighttime hours would have a fairly light blue sky. Sunrise happens fairly quickly, but honestly, I don't spend most of my time in the game watching the sun rise and set. I'd rather have a quick sunrise than a bright sky during most of the night.
Posted on October 6, 2012 6:02PM by chinagreenelvis
Nevermind, I've found a way to keep it subtle.

Updated to version 5.02 - Made sunrises less abrupt
Posted on October 6, 2012 6:21PM by chinagreenelvis
Also fixed a problem with the exposure when using camera
Posted on October 6, 2012 6:37PM by chinagreenelvis
Seriously though, this is it. I need to stop editing the aesthetics or I'll wind up spending my whole life doing nothing but tweaking the GTA weather cycle. Any updates from here on out will only be bugfixes, and hopefully there aren't any more of those.
Posted on October 6, 2012 6:50PM by chinagreenelvis
Much better, good work and thanks.Also was a good idea to disable DOF by default, eats too much FPS to be standard.

I have one last question: VignetteAmount, the scale is 0-10 or 0-100?

Cheers.
Posted on October 7, 2012 8:08PM by MarkC9
Normal values are 1 to 10 but can be set higher.
Posted on October 8, 2012 12:24AM by chinagreenelvis
Updated to version 5.03 - Fixed a slight problem with blurriness, sharpened the default settings and lowered the noise, adjusted timecyc and enbeffect brightness values to improve consistency between interior and exterior spaces.
Posted on October 9, 2012 2:05AM by chinagreenelvis
I love you CGE, thanks for the support 10/10
Posted on October 11, 2012 8:22AM by kont1
@CGE-Is there any individual file to fix the floating square bug in sky in-game like your red sky fix.If any please share as i fixed that transparent texture bug I once discussed with you and now found this in an ENB.
Posted on October 20, 2012 2:26AM by SKS
The red sky fix *will* get rid of the floating square... but it forces you to use the default GTA skies and clouds. I tried to find a shader that would do both, but I don't think one exists.
Posted on October 22, 2012 1:46AM by chinagreenelvis
Well, actually, I take that back, sort of. There is a fix out there that will change the square from red to white, and make the square disappear under most circumstances, but every once in a while you'll see "white skies" appear for a few frames, depending on where you're at on the map and what direction you're looking in.

Version 1.4.3 of CGE ENB has this fix. It's under the "Extra Files" folder.
Posted on October 22, 2012 1:50AM by chinagreenelvis
Thanks for that valuable info mate.I will soon try to test that.
Posted on October 23, 2012 12:55AM by SKS
but one more query mate as the square was not red but of grey color probably in all ENB I tried so if sky color will be light blue then that white square will look awkward,isn't it?
Posted on October 23, 2012 1:02AM by SKS
I don't know. I guess it depends on which version of ENB you use. That's all I got.
Posted on October 23, 2012 3:17AM by chinagreenelvis
i mainly use low end enb as I have a geforce gt 520.Can it handle high end enb?In which end range video card is classified?
Posted on October 23, 2012 6:33AM by SKS
I really don't know.
Posted on October 23, 2012 5:41PM by chinagreenelvis
Why aren't there any reflections on the cars?! An ENB without car reflection is like GTA without Cars
Posted on October 28, 2012 8:14AM by DominoCity
I see car reflections. I spent a pretty fair amount of time trying to make sure they looked "just right" to me.

Make absolutely sure you've installed it correctly and that you haven't changed the settings or aren't using a different enbseries.ini. If all else fails, try increasing the values in the Reflection 1, 2, and 3 sections of that file and see if it makes a difference.
Posted on October 28, 2012 1:47PM by chinagreenelvis
Also, you can clearly see it in some of the screenshots above. I know the cars are wrecked in most of the pictures, but you can still see that they're reflective.
Posted on October 28, 2012 1:51PM by chinagreenelvis
Also, in the demo videos on the left...
Posted on October 28, 2012 1:58PM by chinagreenelvis
Question for you sir, the East side of Algonquin (the "UN" building, Panoramic building, etc...) as well as all of the first island (Broker etc...) all of the buildings are dark at night, no light from them. Just wondering if you had a thought as to what may have caused it. Going to troubleshoot a bit later today.
Posted on October 31, 2012 3:24PM by DLer
@chinagreenelvis-any way to remove the noise grain in your enb mate?and can I use iCEnhancer fxaa file as proxy library in your enb?
Posted on November 2, 2012 11:50PM by SKS
@DLer, I'm not sure, but I do know that window lights in 1070/EFLC aren't enhanced by ENBSeries. If the lights are going out completely, it sounds like an unrelated problem.

@SKS, just set NoiseAmount to 0.0 in enbconfig.txt! You silly person. And yes, you can use any additional dll files with the proxy library in any ENB version.
Posted on November 3, 2012 6:20AM by chinagreenelvis
Additionally, you can either delete effect.txt (which will get rid of the embedded FXAA as well as noise and sharpening effects). You could also totally disable those effects by editing effect.txt and commenting out the code that defines them. For instance:

#define ENOISE

becomes

//#define ENOISE

Unfortunately, there isn't an easy way to disable FXAA without deleting the whole file.
Posted on November 3, 2012 6:24AM by chinagreenelvis
Im loving it! Thanks man! 10!
Posted on November 9, 2012 2:58AM by miked79
tinted windows are so transparesncy, how can i fix this? http://fastpic.ru/view/48/2012/1127/8beb1438e8fa536e4c5f6b632fcece87.jpg.html

p.s. (car by smokey)

Posted on November 27, 2012 8:54AM by Escobar
Either you're experiencing a mod-related bug, or you can tweak the reflectiveness of car windows in enbseries.ini. The readme file contains a link to the website that explains each parameter and which ones you should try changing.
Posted on November 28, 2012 1:50AM by chinagreenelvis
i change OpacityMultiplier to 1.0 and now it`s work perfect, seks for enb, good work)
Posted on November 28, 2012 11:24AM by Escobar
Hey CGE, I noticed you marked the parameters in enbseries.ini as 0 for most reflection options.

ReflectionAmountMultiplier=0

SpecularAmountMultiplier=0

SpecularPowerMultiplier=0

I've found these actually do work in-game. It seems setting them to "0" in fact defaults it to 1.0, however increasing to 1.5 has a noticeable increase in reflections. At 0 ("1.0") it still looks quite respectable, so I wouldn't change it or anything, just pointing out that the options do indeed work with EFLC (and I'd reckon therefore 1070).
Posted on December 12, 2012 8:01PM by MarkC9
Interesting. Do you find that any of the other parameters in the [ENVIRONMENT] section have similar effects?
Posted on December 14, 2012 1:19PM by chinagreenelvis
Great enb ! I have a question and CGE seems to be the most helpful, So i will ask it here.

Is it possible to just use the color correction option in the enb? I was experimenting with settings to see what I could still get out of my (soon to be replaced)gt 460. Using you're enb and the options in the 310 beta drivers, I managed to get some really good looking results. Anyway I was wondering what I would need to enable just the color correction in game. Basically trying to see what the driver settings will do on their own. Thank you in advance

Posted on December 20, 2012 12:13PM by gslack
I've removed the ability to use original post-processing effects, but you can use FXAA to do color correction. Edit the following line in enbseries.ini:

ProxyLibrary=FXAA.dll

And use FXAA_tool.exe to adjust the settings (after dropping the files into your base directory).

http://gtaiv.chinagreenelvis.com/enb/FXAA.rar
Posted on December 23, 2012 9:50PM by chinagreenelvis
Sir, will you be making any updates with the release of ENB v0.135? Just wondering!
Posted on February 26, 2013 10:17AM by DLer
bad timecyc...

Rated: 1/10
Posted on July 19, 2013 8:29AM by BFTDavis
best ENB for eflc!! It just look amazing! No problems at all and for my rig it's very fps friendly. This ENB is not just for who wants to fix the red sky bug, it's a real top ENB. Thanks chinagreenelvis! I was almost leaving behind this ENB thing for EFCL since most of them are only for gta 4 1.0.4.0.
Posted on September 1, 2013 1:11AM by luchi
I've tried the more popular ENB's and I have to say this is by far the best one. All the bug fixes included (by the guy who originally figured them out) plus tons of custom presets. Not to mention original file back ups (in case you forget to back up like I did). Very organized file packing. This is the complete package and the easiest ENB to work with if you just want to mod an play with no BS. CGE should really get a lot more recognition for such a great ENB package.
Posted on November 15, 2013 10:13PM by Modrod
i'm using Steam EFLC 1.1.2.0... (currently just trying TLAD), and I have to say this has been one of the easiest ENB's to get good results from. The DOF is not as clean as the bokeh-style used in eg gp65cj04's ENB's (http://enbseries.enbdev.com/forum/viewtopic.php?f=7&t=976) , but i found the latter not really usable for gameplay.

(And a lot of the ENB's using it didn't work well on 1.0.7/1.1.2.0

for me)

CGE's static DOF works really well, but it'd be great to see some of the other higher quality implementations available for use in screenshots. I can't remember who's enbeffect.fx it was but it had some "poisson" code in it. But again as mentioned that had auto-focusing in it that wasn't really suitable for gameplay.

anyway Great work CGE!

some of my images here:

https://www.facebook.com/jmp909/media_set?set=a.10153900397675402.1073741841.865375401&type=3

a bit dark some of them i know, and not the best ENB shots you'll see, but i was trying a few different styles (film grain etc)

(the ones that aren't CGE, i've made a note on)
Posted on March 10, 2014 8:12AM by jmp909
by the way i tried to add Dax1's ENB fix for EFLC, so I could enable SSAO (Ambient Occlusion)

the proxy chain goes like this:

d3d9.dll -> dax.dll -> d3d9_SweetFX.dll -> d3d9_Sharpen.dll

but everything went very very dark, practically black. i think the problem is that dax1 has shaders and cge has shaders and the two clash

Wondering if anyone knew how to get SSAO enabled for CGE?

thanks

J
Posted on March 10, 2014 8:20PM by jmp909
Thanks for all the great feedback, guys. I'm surprised anyone even knows about this ENB version anymore...

Update: Version 5.05 - Created a "performance" version in addition to the fully realized mod the way I meant it to look. Updated the dxd9.dll file and swapped out SweetFX for SMAA in the regular version, which seems to give me a little bit of a performance boost.
Posted on August 4, 2014 9:02PM by chinagreenelvis
Update: Version 5.06 - Some tweaks to the default settings, three performance versions now available, pulled DOFBlurAmount from the settings file and put it back in enbeffect.fx.
Posted on August 5, 2014 2:51AM by chinagreenelvis
jmp909: I've combined Dax1's shaders with CGE ENB in an experimental 6.0 version, available for download from the same location. It seems to be working well for the most part with minimal features disabled. SSAO doesn't seem make a huge difference, but it's functional.
Posted on August 5, 2014 10:24AM by chinagreenelvis
Sorry, you must be registered and logged in to post a comment. Log in now!