ChinaGreenElvis ENB 4 for GTA IV and EFLC

by chinagreenelvis
Please explain why you're reporting this file:

Cancel
 
• ENBSeries post-processing
• 1.0.7.0 and EFLC compatible
• Easily modified
• Adjustable static depth of field
• Motion blur
• FXAA anti-aliasing
• Custom visual presets
• Increased draw distance
• Timecycle written from scratch
• Crash-free
• Proper rendering of cutscenes
• No overbrightness/darkness
• Works in multiplayer
• No red skies/no black horizon
• Improved vehicle shadows

This mod is highly customizable. You are encouraged to change the settings to suit your tastes. Custom presets are included!
Rating:
8.48/10 - 33 votes
Downloads: 3,268
Added: September 27, 2012 7:53PM
Last Downloaded: November 24, 2014 10:42AM
File Size: 87 B
» Author Website
» Author Email

Sorry, you must be registered and logged in to add a video to this file. Log in now!

Is the FPS the same as on 2.0? Cuz in 3.0 the FPS was * up.

Btw, best enb i've used for 1.0.7.0.
Posted on September 28, 2012 12:34PM by eabettebalterze
Anyone who rates this less than 10 is sorely mistaken. Ignore your subjective opinion of how it "looks to you" and appreciate the work and efforts. He fixed the red sky bug! He fixed the horizon issue! No one else out there is working on EFLC as hard as this guy. PROPS
Posted on September 28, 2012 12:47PM by DLer
Really great job !
Posted on September 28, 2012 1:17PM by GEL060
thanks friend :)

Now I'm going to try and present a video
Posted on September 28, 2012 1:38PM by raggazam
Nice ENB but low FPS, just tried it. I'm better of with CGE 2.0 ...

But i'm sure about, that this enb is amazing on a gtx 670 or 680

Posted on September 28, 2012 3:28PM by eabettebalterze
Best ENB for 1.0.7.0 !

Thanks you :-)
Posted on September 28, 2012 3:29PM by TucSky
Thanks for your hard work and perseverance

Easily modified

But no one seems to do so

10/10

Posted on September 28, 2012 7:15PM by gbaoye
eabettebalterze, try using low quality DOF or disabling DOF altogether. The readme explains how, and that should boost your FPS.
Posted on September 28, 2012 10:01PM by chinagreenelvis
Wish to provide

Low Medium High enbseries.ini

Grateful

Given you are familiar with the parameters, modify them easily.
Posted on September 28, 2012 11:24PM by gbaoye
Intel Core i3-2120 3.30ghz

Sapphire Radeon HD 6670 1gb GDDR5

6GB DDR3 1333

Do you think my rig can handle it?
Posted on September 29, 2012 4:11AM by Regor245
The effort and the discoveries themselves (i.e. red sky fix, shadow fixes, etc) warrant 10/10 as future ENB builds from others can now include these fixes. Then we look at the visuals and it's up there with all others, 9-10/10. Finally we look at how the mod is setup, how easy it is to customize by comparison, and we have even more reasons to vote 10/10. I also don't think there's another ENB build that changed headlight strength/distance and small tweaks like this.

It's near perfect, good work. It's unfortunate about the rating, but that's the world for ya; full of idiots. Just know every one of us that plays EFLC and has a functioning brain located in our skull applauds you for this release.
Posted on September 29, 2012 7:18AM by MarkC9
Also this might sound crazy but CGE has acted as a bug fix for me. Ifell asleep with my game on last night in multiplayer. Woke up 8 hours later... still hadn't crashed. :o Incredible. I actually crash significantly more often when playing vanilla EFLC... figure that one out lads o_0
Posted on September 29, 2012 7:23AM by MarkC9
Just the best, no more words are necessary, perfect ENB, perfect support, perfect fixes, realistic, natural, just perfect, thanks a lot CGE, you are the best.
Posted on September 29, 2012 11:27AM by kont1
oh * awesome good work !! 10/10
Posted on September 29, 2012 3:40PM by RedBullMaster
This just looks so NICE, just for some reason every single shader pack version from everybody always crashed my game. Only original shaders worked on my EFLC and they were never any good for these enb's. I don't get it. I can do anything to GTAIV till v1040. I have ENB's in Dirt3, MassEffect3, Mafia2, Driver SF and Tribes Ascend. Some FXAA injectors in JC2, BF3 and Sleeping Dogs. All works on W7/64bit,GTX560...I'm gonna reinstall EFLC and try again.
Posted on September 29, 2012 4:47PM by tall70
thank you for all the work on ENB

but before to test it

..i've a question pls ;



is this the Default preset on the screenshots ?
Posted on September 29, 2012 7:17PM by Chooby
The screenshots are the default preset, yes.

And I really just want to say thanks to all you guys who've given the mod praise, it definitely means a lot!

As for low, medium, and high settings, I don't think enbseries.ini has too many parameters that actually would affect fps since most of the processor heavy functions don't work in 1070/EFLC and have been disabled already. The only tweak that might make a difference is setting DetailMapEnable to false. Come to think of it, I'm not sure that setting actually works, either. Does anyone know?

Edit: looks like I accidentally left a few of those non-working effects set to true, but I'm not sure it matters. The readme file has a link to the enbseries.ini tutorial page and you can use that to make changes.
Posted on September 29, 2012 9:53PM by chinagreenelvis
Just here to say: Your red-sky patch works so beautifully, mate. You might remember me; I spammed your 3.01 download here :P

This ENB: http://www.gta4-mods.com/misc/difasoftware-enb-series-f17161

works great for me. Too bad I can't get CGE's visual presets now. Seems like L3EVO's nVidia support did it for me. Thanks to you, red sky R.I.P.
Posted on September 29, 2012 10:45PM by Fulcrum
Finally! Thanks for a true, bugless, ENB! This really gives the game current-gen graphics.
Posted on September 29, 2012 11:38PM by SpoonTheMan
I'll also add gents: I've been testing injectSMAA for an extra layer of anti-aliasing and it looks great with the mod. Adding, so not replacing the FXAA or anything like that, just enabling ProxyLibrary in enbseries.ini and setting it to the SMAA dll. It eats an extra 4-10fps depending on what settings you use in it's INI, but things such as faces of ped models and complex architecture on buildings look far better with it enabled. I don't generally use it as I prefer to get full FPS, but if you favor visual prowess I highly recommend adding it fellas.
Posted on September 30, 2012 7:34AM by MarkC9
Light on the bytes, without bugs... 1.0.7 version. No redsky, in-game customization, in other words, Perfect ! Thanks a lot mate !
Posted on September 30, 2012 10:58AM by Elnum
if i have to say something here about the final release of this ENB i would say that i am not satisfied as i was with the 3.01 china came out with because that one had a better looking over all feel i don't know if its just me or someone else also noticed that the visual distance and other graphical effects are not as good as they were in that version but still good effort and i wanted to know why this one is missing ICE visual preset as previous version had it ?
Posted on September 30, 2012 1:34PM by Glasswings21
You can still use the old color filters, but in my opinion they don't work as well with this version because of the new timecyc.dat file, which I wrote from scratch.

The draw distance has been decreased slightly to avoid the black horizon issues that happen when you're in a helicopter.

I'm considering making a version that uses the default GTA timecyc file; my old one was a modified version of the original. For the new one I decided to keep the colors consistent between weather types for a more natural look, but as you say, it does change the feel quite a lot.
Posted on September 30, 2012 4:22PM by chinagreenelvis
Meh, on second thought, I don't think I will. But you can still use the old timecyc.dat from 3.01 and adjust the brightness and contrast settings accordingly in enbconfig.ini.

Anyway, re-uploaded with the enbseries.ini settings changed to make sure non-working effects are disabled.
Posted on September 30, 2012 5:01PM by chinagreenelvis
10/10 i used the old CNE ENB and it was the best i could find until now..

my settings so far...

float4 Brightness = 5.0;

float4 Contrast = 5.0;

float4 ColorSaturation = 9.0;

float4 BloomAmount = 2.0;

float4 BloomAdd = 2.0;

float4 SharpeningAmount = 12.0;

float4 SharpenSamplingRange = 0.0;

float4 NoiseAmount = 0.0;

float4 VignetteAmount = 0.0;

float4 DOFBlurAmount = 0.0;

float4 FlareIntensity = 0.3;
Posted on September 30, 2012 9:55PM by kitoxx
excuse my noobiness CGE but how do i edit the amount of motion blur.

enbeffect.txt refers to motion blur but i am not sure what value to change Registers:

//

// Name Reg Size

// ---------------------------- ----- ----

// globalScreenSize c44 1

// Exposure c66 1

// motionBlurMatrix c72 4

// TexelSize c76 1

// dofProj c77

// dofDist c78 1

// dofBlur c79 1

// gDirectionalMotionBlurLength c80 1

// ToneMapParams c81 1

// deSatContrastGamma c82 1

// ColorCorrect c83 1

// ColorShift c84 1

// PLAYER_MASK c85 1

// GBufferTextureSampler2 s0 1

// GBufferTextureSampler3 s1 1

// HDRSampler s2 1

// BloomSampler s3 1

// AdapLumSampler s4 1

// JitterSampler s5 1

// StencilCopySampler s6 1

////////////////////////////////////////////
Posted on September 30, 2012 10:03PM by kitoxx
Try changing some of the values in the section with the header

// Motion Blur

It's towards the bottom of enbeffect.fx. I never created any variables for that section, but you can still alter the code, I'm sure.
Posted on September 30, 2012 11:36PM by chinagreenelvis
ahh ok,i will try when i get home... ".fx" not ".txt" thanks CGE.

this beast should be FEATURED!!!
Posted on October 1, 2012 1:03AM by kitoxx
@chinagreenelvis- Can you config your ENB for low end PC also?
Posted on October 1, 2012 8:53AM by SKS
Probably not, but the only way to find out is to try.
Posted on October 1, 2012 10:31AM by chinagreenelvis
@chinagreenelvis- yeah i tried by changing the resolution to 800X600 in the enbconfig.ini and also the anti-aliasing level to 1 and 0 but it still lags.By the way can you help me with one thing ?
Posted on October 1, 2012 11:38PM by SKS
Neither of those settings would have any effect; antialiasing in enbseries.ini is disabled by default. You might get better FPS by changing the actual in-game resolution and lowering your settings in the GTA IV menu as much as possible.

Anyway, ask away.
Posted on October 2, 2012 2:36AM by chinagreenelvis
I have used several low end enb by many and all had the same problem whether it be 0.079 SORA or 0.081.The bug is that the world textures(buildings,roads etc) are becoming transparent and flashing,every vehicle body is becoming transparent as soon as Niko or Luis Or Johnny enters.Or just to be short every world details becomes transparent with just basic polygon design of each to be seen everytime.It occurs on a regular basis with getting fixed automatically after some seconds and then happening again.I have not encountered this bug in 0.082 enb but it lags too much.Is there any fix for this or where can I upload screens with those bugs so that you or anyone else can better understand and suggest me what to do?
Posted on October 2, 2012 7:15AM by SKS
I have used several low end enb by many and all had the same problem whether it be 0.079 SORA or 0.081.The bug is that the world textures(buildings,roads etc) are becoming transparent and flashing,every vehicle body is becoming transparent as soon as Niko or Luis Or Johnny enters.Or just to be short every world details becomes transparent with just basic polygon design of each to be seen everytime.It occurs on a regular basis with getting fixed automatically after some seconds and then happening again.I have not encountered this bug in 0.082 enb but it lags too much.Is there any fix for this or where can I upload screens with those bugs so that you or anyone else can better understand and suggest me what to do?
Posted on October 2, 2012 7:20AM by SKS
Sorry, man - you'd have to e-mail Boris Vorontsov, he's the original creator of the ENBSeries.

http://www.enbdev.com/index_en.htm
Posted on October 2, 2012 12:45PM by chinagreenelvis
I've just noticed that some of the weather transitions are really bad, so I'm redoing the skies using the original timecyc as a reference. Not sure whether to release it as 4.1 or 5.0.
Posted on October 2, 2012 12:52PM by chinagreenelvis
well thanks man but can you just give the precise word of this bug?
Posted on October 3, 2012 1:45AM by SKS
I have no idea; I've never heard of it before. Boris is the man you want to talk to.
Posted on October 3, 2012 2:14AM by chinagreenelvis
Yeah I send him an e-mail with screenshots.Can I send the same to you too so that if you can try and check out?
Posted on October 3, 2012 5:48AM by SKS
@SKS.....atleast post some system specs so we know whether your running onboard graphics or something stupid....as CGE said he's not resposible for your issue..

this is soo awesome that you killed the farclip horizon issue and kept the draw distance without reintroducing redsky, ive been playing with the enbseries.ini and found my preferred settings but yes i have noticed the weather changes almost instantly and my roads dont seem to get wet and reflective anymore i hate to ask but could it be caused by reflection settings in enbseries.ini or DKT70 roads.

once again 10000000/10. thank you CGE

Posted on October 3, 2012 11:02AM by kitoxx
awaiting admin approval???? but i already have it??

did you update it CGE?
Posted on October 3, 2012 11:06AM by kitoxx
@SKS - Sending me screenshots won't do any good. I honestly would have no idea how to help you. Sorry!

I know Boris mentioned "invisible" objects and textures somewhere on his site with older versions. That's the best I can hope to tell you.

@kitoxx - I have zero problems with wet roads. This mod shouldn't make any changes to how long the weathers last. More than likely, you've got too many or just conflicting mods installed.

The title was updated on this page to remove the "final release" part, since it was only meant to distinguish this 4.0 from the beta versions I had up for a while. I've just updated the mod and given the timecyc.dat file a huge overhaul so that the weather transitions look much nicer (no more big solid blue sun on black clouds, etc). The current version is now 5.0, and I've made a new page for it, which is also probably awaiting admin approval.

Posted on October 3, 2012 2:51PM by chinagreenelvis
@kittox-for what and why CGE will be responsible? I just asked him because of the main problem.

And regarding my PC,specs are

Amd Phenom II X4 965 Black Edition @3.40 GHz processor,

Corsair XMS 3 4096 MB DDR 3 @1333 MHz System memory,

MSI 890GXM-G65 with GPU Radeon HD 4290 Gaming Series inbuilt and factory overclocked mainboard.
Posted on October 4, 2012 12:11AM by SKS
so dark.

cant see anything
Posted on October 4, 2012 2:50PM by RedBullMaster
@RedBullMaster, either you're trolling, you didn't read the readme file on how to make brightness/contrast adjustments, or you've done something wrong.
Posted on October 4, 2012 3:25PM by chinagreenelvis
he is not trolling @chinagreenelvis when i also used this enb the game was so dark and lagged like *
Posted on October 5, 2012 4:56AM by SKS
That information alone doesn't really help pinpoint the source of the problem. Have you used an ENB mod version that does work? If not, then likely the problem isn't my mod, per se, but ENBSeries in general.
Posted on October 5, 2012 2:50PM by chinagreenelvis
Visit this link and download the original mod by Boris.

http://gtaiv.chinagreenelvis.com/enb/0.082Beta/

Use it with a *clean* install of GTA IV and tell me what happens.
Posted on October 5, 2012 2:53PM by chinagreenelvis
thnx CGE i will look at 5.0 now
Posted on October 6, 2012 6:08AM by kitoxx
it is so good ENB.....!!!!!
Posted on October 11, 2012 9:53PM by wong530
Sorry, you must be registered and logged in to post a comment. Log in now!