Grand Theft Auto 4.5 Mod Pack [Beta]

by Variois. viper33assasin
Please explain why you're reporting this file:

Cancel
 
BACK UP YOUR GAME! IF THERE ARE ANY ERRORS PLEASE COMMENT!

After years of modding my GTA, I decided that I should just create a mod pack and call it GTA 4.5 which will allow people with original GTA IV to not go through the hassle and just install a bunch of stuff at once.

This mod pack will add enbfx, HQ cars + bikes, script mods, character mods, minor tweaks like better explosions, blood and gore, etc.

I did the modding on 1.0.4.0 version, up to you if you want to try it on different versions.

Please play before rating, if there is a problem, report it. Report Problems in Comments Section, I will help!

If you see no textures at all, like nothing, go to commandline.txt and remove -nomemrestrict OR just change resolution from 60hz to 59hz vice versa.

Visit & Sub to my YouTube channel! http://www.youtube.com/mkeliteworksX

Make sure you read the controls for each mod, or else you are gonna be lost.

-Custom ENB nlgzrgnENB v1.1, Lightly Modified by Me.
-Fus Ro Dah!
-AC130
-Trainer with all you need
-Car Showroom
-All custom HD cars, Just cars that I liked, and installed over time.
-5-8 cars are drift cars.
-Huge Countryside Mountains V Fully Functional, with traffic etc.
-Traffic Control
-Zombie Survival Mission by Lighthouse
-Ragdoll Mod
-Nuke Mod
-FIRST PERSON
-SUPER TRAINER
-REAL SHOPS (IN NEXT VERSION)
-SPEEDOMETER
-Some CUSTOM Peds
-CUSTOM USABLE MODELS
-OBJECT SPAWNING
-CUSTOM COD Weapon Sounds
-Extra Blood And Gore
-Bigger and Stronger Explosions
-MINIGAMES mod(COD ZOMBIES, GANG WARS)
-Characters: (woody, buzz, horse, dog, Kane, spiderman, Undertaker, Mario, Luigi, many others) Replaces: LOTS OF STUFF
Rating:
9.32/10 - 19 votes
Downloads: 6,962
Added: April 17, 2013 2:37PM
Last Downloaded: October 23, 2014 4:50AM
File Size: 4.75 KB
» Author Website
» Author Email

This looks so cool! APPROVE!!!
Posted on April 17, 2013 4:40PM by ModxSwagg
Why did it not get approved? Took me a while to put it together so let me know, maybe I can fix it up.

Thanks
Posted on April 17, 2013 4:46PM by viper33assasin
if any one of the original mod authors asks me to remove it, i'll have to take it down.
Posted on April 17, 2013 11:46PM by rappo ✮
Before taking it down, would it be ok if you could just notify me? I would update the mod without the the one that needs to be out.

Thanks!
Posted on April 18, 2013 12:22AM by viper33assasin
nice u got minigames in there :)

is that also my old nuke mod?? has nuke gun and jihads??
Posted on April 18, 2013 12:40AM by Ra's al Ghul
Can I only have your Custom ENB nlgzrgnENB v1.1? I can't download that big. Please! Thanks :)
Posted on April 18, 2013 12:53AM by IceFluxx
@viper33assasin: sure! will do
Posted on April 18, 2013 1:35AM by rappo ✮
Why didn't you make it a torrent download??
Posted on April 18, 2013 3:24AM by shubham1611
Please remove it.

I didn't give permission to include the Pink Panther or the Troll Ped.
Posted on April 18, 2013 3:56AM by Quechus9
Any other download links?
Posted on April 18, 2013 5:54AM by MkeCra
i want ryback
Posted on April 18, 2013 7:00AM by Stig_TheDriver
While I personally prefer to install mods one-by-one, this is going to be great for people who find GTAIV modding to be a little daunting. 10/10 from me. :)
Posted on April 18, 2013 8:06AM by Geosmith
A mod pack is a wonderful idea and good job putting this together, but two things to note:

1) It should have a theme. What does the AC-130 script have to do with drift cars? Real shops for realism, sure, but then a troll ped, woodie, and I can do the fus ro dah? If you wanna go this route (a massive pack of random mods) you should probably up the ante and include more script/ASI mods. As right now there's only so many and they seem arbitrarily picked. I'm assuming theres a * ton of models already, but if not, more models too

2) Unfortunately you cannot post these packs on sites like this without the permission for each author. You're better off making a thread about it on something like GTAForums, or loading it up into a Torrent site.
Posted on April 18, 2013 8:35AM by MarkC9
You have to get permission of everyone, though!
Posted on April 18, 2013 9:57AM by ModxSwagg
@Ra's al Ghul yes, it just has the nuke mod. Thanks for making it.

@MarkC9 To be honest, I have submitted only two files, this and a loading screens mod. There really isn't a theme here, as I said in description, just my GTA mods all in one download and easy to install.

@IceFluxx Sure, I will post here soon.
Posted on April 18, 2013 10:37AM by viper33assasin
cant start the game now. good I have a backup
Posted on April 18, 2013 10:38AM by zxcvbnmq1
@zxcvbnmq1 whats the error? was your game 1.0.4.0 and 100% original?
Posted on April 18, 2013 10:48AM by viper33assasin
@IceFluxx https://mega.co.nz/#!kowVkSya!TBV6wWaT9JDpWdxZSWqx4kJF35UAfRZH39YWA3K0KM4

Posted on April 18, 2013 10:54AM by viper33assasin
no prob glad i could help ;)

and im glad u added, i tried to upload it last night but rappo would not approve, maybe he is upset over boston, i dont support terrorists lol
Posted on April 18, 2013 2:02PM by Ra's al Ghul
haha lol
Posted on April 18, 2013 4:55PM by viper33assasin
Thanks viper!
Posted on April 18, 2013 8:52PM by IceFluxx
no prob :)
Posted on April 18, 2013 10:02PM by viper33assasin
Can you upload other link because when i downloading its getting stop i dont get it :D
Posted on April 19, 2013 9:07AM by mixdrift
@mixdrift where do you want it to be uploaded?
Posted on April 19, 2013 2:44PM by viper33assasin
It's cool, but the game crashes after about 10 seconds! How can I fix this issue?
Posted on April 20, 2013 7:35AM by Larry_King
The crash of the game, is beacause of the d3d9's files, but without those, the game looks bad
Posted on April 20, 2013 7:52AM by Larry_King
hmmmm....really? after 10 seconds it crashes? what kind of hardware you got?
Posted on April 20, 2013 6:09PM by viper33assasin
Here you are my specs:

CPU: Intel Core i5-3570k 3.4 GHz

Mainboard: ASRock Z77 Extreme 4

RAM: Corsair Vengeance Low Profile White 1600 MHz 8 GB (2x4GB)

Hard Disk: HDD Western Digital Caviar Blue 1TB + SSD Samsung 830 64GB

GPU: Gigabyte HD 7970 OC 3GB

Monitor: Asus ML239H 23" Full HD IPS

Power Supply: XFX Pro Series 650w

OS: Windows 7 Ultimate x64

Case: CM 690 II Advanced USB3 Version Nero con finestra laterale

The crash is caused by d3d9's files, infact without those, the game run without any problem but it looks bad... I had this issue with other iCEnhancers and ENB's too

P.S. Sorry for bad english
Posted on April 21, 2013 7:18AM by Larry_King
I've fixed that issue (I have re-installed the 1.0.4.0 patch after the installation of the ENB of this fantastic mod). 2nd issue: if I copy all the files of GTA 4.5 (with all the scripts), the game crash
Posted on April 21, 2013 10:29AM by Larry_King
@Larry_King *...I wonder if you are the only person with the problem...it works perfectly fine on mine. What you should try doing is reinstall the game, update to patch 1.0.4.0 and then try. If it still happens, maybe you will need Microsoft .Net Frameworks 3.5 and 4, or maybe more versions lol.
Posted on April 21, 2013 1:03PM by viper33assasin
I can't download the file that you have done uploaδ. Can I get a different link in my e-mail?? (sofokl56@gmail.com)
Posted on April 21, 2013 1:43PM by cySOFOSxx
@viper33assasin Ok, now I'll try to reinstall GTA IV. Thank you for disponibility :)
Posted on April 21, 2013 2:40PM by Larry_King
@viper33assasin I've reinstalled GTA but it doesn't work... That * d3d9.dll crash with something!
Posted on April 21, 2013 4:33PM by Larry_King
@cuSOFOSxx tell me where to upload it, I cannot email it.

@Larry_King Sorry bro, I am not sure why that is happening :/ try putting some files at a time, and that way you will find out what it is.
Posted on April 21, 2013 6:10PM by viper33assasin
@viper33assasin You can upload this link at 4shared or FilesTube

thank you.I will wait for an answer.
Posted on April 22, 2013 7:14AM by cySOFOSxx
@viper33assasin You can upload this link at 4shared or FilesTube

thank you.I will wait for an answer.
Posted on April 22, 2013 7:23AM by cySOFOSxx
@viper33assasin I think it's an issue caused by DirectX
Posted on April 22, 2013 9:35AM by Larry_King
@cySOFOSxx

http://www.4shared.com/rar/Sl2hRC-v/GTA_45_1.html

make sure you rate!
Posted on April 23, 2013 12:04AM by viper33assasin
thanks a lot bro
Posted on April 23, 2013 6:26AM by cySOFOSxx
@viper33assasin All those bugs was caused by the "enbeffect.fx" file, I don't know why; the only thing I know, it's that the game works without that file, but whitout it, the ENB isn't complete and the brightness is very high
Posted on April 23, 2013 7:20AM by Larry_King
RAte it 10/10 classic dude :D no its not a joke i like it :)
Posted on April 23, 2013 8:17AM by mixdrift
@Larry_King I wonder if you are the only one with this problem?

Posted on April 24, 2013 12:47PM by viper33assasin
Yes, I think I'm the only one with this problem, but why!? All the the graphic mods that I used before this has worked, and now, no one mods works! I've tried some ENB's and iCE's but nothing

P.S. Sorry for bad english
Posted on April 24, 2013 2:09PM by Larry_King
*...I have no idea lol has to be something with video card drivers, directx, .net framework
Posted on April 24, 2013 8:10PM by viper33assasin
nooooooooooooooooooo out of memory!!!!!!!!!! help me please

amd dual-core prosessor a4-3300 m

amd radeon HD 6480G

ram 4GB DDR3

help me please

Sorry for bad english
Posted on April 24, 2013 9:56PM by motiwyl
ya your card is very slow and so is your processor. What you can try is playing on low graphics settings that is all I can say.
Posted on April 25, 2013 12:43PM by viper33assasin
thanks.
Posted on April 29, 2013 5:17AM by motiwyl
i need is mod without enb and without commandline you can do this for me?

Sorry for bad english
Posted on April 29, 2013 5:25AM by motiwyl
if game doesnt start because of d3d9.dll then reinstall directx

scripthook was developed with this...

http://www.microsoft.com/en-us/download/details.aspx?id=9155
Posted on April 29, 2013 10:10PM by Ra's al Ghul
^Thanks for that!!
Posted on April 29, 2013 10:34PM by viper33assasin
@motiwyl all you gotta do if you want to disable enb is remove d3d9.dll and also, get original shader files, well..there are way more files than that, :/ I do not even remember so many of the files were replaced.
Posted on April 29, 2013 10:38PM by viper33assasin
^Thanks
Posted on April 29, 2013 10:50PM by motiwyl
Thanks for using my ENBSeries settings w/ your mod. This is awesome! I wish there was an 11/10! ;)
Posted on April 30, 2013 2:52PM by //nlgzrgn/
I'm having a strange issue: I can't download the file. It gets up to about 40% and just freezes and doesn't continue. I gotta head out so I'll leave it running for the day to see if it goes anywhere
Posted on May 1, 2013 7:48AM by lionheart2243
Leaving it on for 4-5 hours didn't help. I've tried 4 times, once it froze around 15% the other 3 times including the 4-5 hour one froze right at 40%. It says 6mins 40 seconds left at 2.4Mb/s. Is there any other source that I can get this from?
Posted on May 1, 2013 1:40PM by lionheart2243
@lionheart2243 http://www.4shared.com/rar/Sl2hRC-v/GTA_45_1.html

Posted on May 1, 2013 10:52PM by viper33assasin
@//nlgzrgn/ NP, and thanks a whole lot to you for making one of the best ENB yet!
Posted on May 1, 2013 10:56PM by viper33assasin
@viper no prob
Posted on May 3, 2013 1:05AM by Ra's al Ghul
Make sure you guys check out my youtube page! http://www.youtube.com/mkeliteworksX
Posted on May 3, 2013 8:57PM by viper33assasin
This is amazing. 10/10.
Posted on May 6, 2013 10:50AM by EbinFugger
Thank you :)
Posted on May 6, 2013 9:56PM by viper33assasin
Works great, looks great. Just awesome. Only bug i encountered so far is that the first mission where you drive your cousin around does not work and freezes the game. Could be related to many thing, might even be an older mod interfering. Anyways nice job =P
Posted on May 9, 2013 6:39AM by pow3rran9er
@pow3rran9er ahh, I did not have story mode in my mind, this was me modding the game over 3-4 years so I couldn't really check that.

Glad you liked it though! :)
Posted on May 9, 2013 4:00PM by viper33assasin
my game is dead it out of memory!!!!!!!!!! I do everything!!!

sorry for bad english
Posted on May 23, 2013 6:52AM by motiwyl
@motiwyl what are your computers specs? because you need at least 1 gb video memory, 4-8gb ram!
Posted on May 23, 2013 12:25PM by viper33assasin
@viper33assasin OMG!!!!
Posted on May 25, 2013 10:38AM by motiwyl
is it me or does anyone else get an unavailable dl link @ mega?
Posted on June 18, 2013 8:44PM by Saunders420
@Saunders420 Works fine for me https://mega.co.nz/#!ghQWFSrZ!Mcw3tQsItVB7VJCG3S2_JgcOZlVOay-eSRI5x4AjuLw
Posted on June 24, 2013 7:00PM by viper33assasin
right on it works now! thanks, iunno what was happening.
Posted on June 28, 2013 7:50PM by Saunders420
Does anyone know if this works for v1.0.7?
Posted on July 3, 2013 12:13PM by itzzoscar
Does anyone know if this works for v1.0.7?
Posted on July 3, 2013 2:08PM by itzzoscar
I'm having some trouble getting the mod to run at more then 15fps. Any ideas?

Here's my specs:

CPU: Intel Core i5-3570k 3.4 GHz (overclocked to 4.2GHz)

Mainboard: ASRock Z77 Extreme 4

RAM: G.SKILL Sniper Series 8 GB (2x4GB)1866MHz

GPU: Evga GeForce GTX 660 Ti FTW Signature2 2GB

OS: Windows 8 x64
Posted on July 28, 2013 2:39AM by Jasper9393
I'm having some trouble getting the mod to run at more then 15fps. Any ideas?

Here's my specs:

CPU: Intel Core i5-3570k 3.4 GHz (overclocked to 4.2GHz)

Mainboard: ASRock Z77 Extreme 4

RAM: G.SKILL Sniper Series 8 GB (2x4GB)1866MHz

GPU: Evga GeForce GTX 660 Ti FTW Signature2 2GB

OS: Windows 8 x64
Posted on July 28, 2013 3:05AM by Jasper9393
@viper33assasin Also I seem to get a Fatal Error (SMPA60) after about 10 minutes of play no matter what I do
Posted on July 28, 2013 3:45AM by Jasper9393
@Jasper9393 I would update graphics drivers. My single gtx 560 would run it at 20fps at 1080p.

Also, for the error, the problem may be the save game file. I noticed this too, if the save game file has a modded car saved, it will crash the game eventually.
Posted on July 31, 2013 3:07AM by viper33assasin
I just purchased GTA 4 via steam, downloaded/installed the game, and patched the game to version 1.0.4.0. I can no longer launch the game via Steam (LaunchGTAIV.exe) and I see errors in the Windows logs whenever I attempt to launch it. I can however launch the game when executing GTAIV.exe, but my screen goes wobbly and cars accelerate on their own (I believe this is built-in to the game for anti-piracy, so I guess the mod is causing that?) If anyone could help me figure out why the game wont launch, and how to get this game running with this mod it would be greatly appreciated!

OS: Windows 7

Windows application logs:

Faulting application name: LaunchGTAIV.exe, version: 0.1.0.0, time stamp: 0x00000000

Faulting module name: paul.dll, version: 1.0.1.14, time stamp: 0x4be32090

Exception code: 0xc0000005

Fault offset: 0x00023379

Faulting process id: 0x5d4

Faulting application start time: 0x01ce9ca4b245661d

Faulting application path: E:\Games\Grand Theft Auto 4\SteamApps\common\Grand Theft Auto IV\GTAIV\LaunchGTAIV.exe

Faulting module path: E:\Games\Grand Theft Auto 4\SteamApps\common\Grand Theft Auto IV\GTAIV\paul.dll

Report Id: f36b7cfc-0897-11e3-a690-5404a62f4fd7

Fault bucket 1885349608, type 1

Event Name: APPCRASH

Response: Not available

Cab Id: 0

Problem signature:

P1: LaunchGTAIV.exe

P2: 0.1.0.0

P3: 00000000

P4: paul.dll

P5: 1.0.1.14

P6: 4be32090

P7: c0000005

P8: 00023379

P9:

P10:

Attached files:

C:\Users\Dale\AppData\Local\Temp\WER454B.tmp.WERInternalMetadata.xml

These files may be available here:

C:\Users\Dale\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_LaunchGTAIV.exe_54854f3158dc81cba7c15a920e6bd7f5fa77544_0fc14fe5

Analysis symbol:

Rechecking for solution: 0

Report Id: f36b7cfc-0897-11e3-a690-5404a62f4fd7

Report Status: 0

Posted on August 19, 2013 1:43AM by druxx89
@druxx89

The steam version is 1.0.7.0 and installing an older patch will only damage the game. Since you own the game, I suggest you download a torrent of GTA IV which is non steam version and is 1.0.1.0 and you will be able to upgrade to 1.0.4.0 and then install this mod.
Posted on August 22, 2013 3:23PM by viper33assasin
im having trouble installing the mod. i coppy the folder to gtaIV but when i enter the game it is now working
Posted on March 20, 2014 1:28PM by BKxRANDY
Hey why in my computer is so lagg !!

My spec :

CPU : intel core i5 2,60GHz

RAM : 4.00 GB

VGA : AMD Radeon HD 7550M/7650M Graphics 1024 MB

OS : Windows 8 - 64bit

Posted on March 30, 2014 9:41PM by velox3
Sorry, you must be registered and logged in to post a comment. Log in now!