New Safehouses Mod v1.0 & Update

by Skorpro
Please explain why you're reporting this file:

Cancel
 
New Safehouses Mod (.asi)
for GTA4 v1.0.7.0 & EFLC v1.1.2.0

Scripted by Skorpro
with ScriptHook 0.51 by Aru (Thx!)

- This modification creates up to 32 new safehouses in GTA IV , TLAD & TBOGT!
- In all safehouses you can find save points and sometimes wardrobes, helis, TV (beta) or a private party.
- You can enable or disable every safehouse!


UPDATE (v1.01 for compatibility only!!!)
http://www.share-online.biz/dl/0RWRT0LMHE68

FAQ:
http://www.gtaforums.com/index.php?showtopic=536895

Clip:
http://www.youtube.com/watch?v=s9WqrK1X16I

Have Fun :)
Rating:
9.13/10 - 67 votes
Downloads: 24,248
Added: December 20, 2012 2:13AM
Last Downloaded: April 19, 2014 12:03PM
File Size: 9.17 MB
» Author Website

Sorry, you must be registered and logged in to add a video to this file. Log in now!

wow great job Skorpro
Posted on December 20, 2012 11:20AM by leec313
Holy shit. Excellent work very well done.
Posted on December 20, 2012 11:21AM by matt19811
HOLY SHIT MAN! NICE WORK SKORPRO!
Posted on December 20, 2012 1:56PM by 2TimesACharm
Very good work dude 10!
Posted on December 20, 2012 2:50PM by CORE.MAX2010
Needs more interiors.
Posted on December 20, 2012 6:25PM by Gingersockman
I installed it directly to my GTA:EFLC game folder; then entered the game and I see no changes to it, what I did wrong or I have to do?
Posted on December 20, 2012 6:34PM by briubirod274
I have Windows 7 64 bit and reinstalled and the following files:

- Aru's GTA IV C + + Script Hook 0.5.1

- Microsoft Visual C + + 2010 Redistributable Package

- Microsoft. Net Framework 4

But still I keep getting this error window, just before starting this game:

"The program can not start because there MSVCP100D.dll on your computer. Try reinstalling the program to fix this problem"

What I can do?
Posted on December 20, 2012 7:36PM by briubirod274
try xlive.dll instead of dsound.dll maybe briubirod274 or download that msvcp100d.dll off a dll site on the web
Posted on December 20, 2012 11:20PM by matt19811
works with 1.0.4.0?

Posted on December 21, 2012 10:13AM by zaipec
Nice job,really,ive installed it on gta eflc and gta iv,A tv ja trabalha?
Posted on December 21, 2012 11:28AM by LS ( GtaModder)
I read that you have to press CTRL + SHIFT + F1, but I see the houses
Posted on December 21, 2012 11:40AM by briubirod274
yeeeeessss ! thk bro !
Posted on December 21, 2012 1:38PM by zorrogk
Don't; seem to work on 1.0.4.0
Posted on December 21, 2012 1:50PM by zaipec
can u make this work with 1.0.4.0?
Posted on December 21, 2012 2:09PM by schoober
Wow, now we can use the Majestic Hotel! :D

Thanks!
Posted on December 21, 2012 2:25PM by RobertBlox
holly shit!!!! this is awesome!!!!!!!!!
Posted on December 22, 2012 12:45AM by dkvlvkvh
nice script worth 10
Posted on December 22, 2012 1:12AM by raynier
Thanx to ALL who like my mod :D

For the guys who get problems to start it:

Try installing the "Microsoft Visual C++ 2010 Redistributable Package"! Make sure to install the linked x86 version, even on x64 systems! Install also "Microsoft .Net Framework 4".

Try to start the game. If still nothing happens install "Visual C++ 2010 Express" (it's for free!) and after this make an Windows Update (for VC++ SP1...)!

!!!! LINKS in README.HTM !!!!

Skorpro
Posted on December 22, 2012 10:32AM by Skorpro
it would be dope if this was possible with 1.0.4.0. anyway u can make it happen, willing to throw cash in a paypal.
Posted on December 22, 2012 12:38PM by CURTIARCHITECT
Dude OMFG!!!! THIS IS BEAST MAN THANKS A MILLION.
Posted on December 22, 2012 6:08PM by Ethan J
hey dude..... its not working.....i have everything that required to this mod.. but when i installed it at my gta 4 direct nothing is happened. so i tried lot of time but it's nothing. very disapointed.
Posted on December 22, 2012 9:57PM by ajinkyathakur
I tried installing all of the required elements (Microsoft Visual C++, .Net Framework, etc), but nothing worked!

Upon trying to run the installer on my x64 machine, it said that the exe's were incompatible.

PLEASE try to find a way to make this mod work without those requirements, because it still can't run on my GTA IV. :(
Posted on December 22, 2012 10:06PM by RobertBlox
I'm pretty new to this, but have been able to successfully install all scripts except for this one... and this one is more of a priority for me. I tried installing this multiple times (to GTA IV), and I get no new safe houses. When I push the ` key and bring up running scripts, this one doesn't show up... Any suggestions? This mod looks awesome and I really want it to work.

Thanks
Posted on December 23, 2012 1:07AM by GONADS125
Interesting. It would be really handy to have a safehouse a lot nearer than the only 3 you get in the original game.

Especially since I don't use any trainers or anything like that to like "fly around" or "teleport" or anything. I always just travel towards the nearest safehouse to save. But this should speed up that process a lot. So I'll try it.
Posted on December 23, 2012 12:23PM by Damage Inc.
Also, I see it's an installer. But could you tell us what files are being installed? I need to make sure that anything that might be replaced is backed up and that I know which files were changed.

And if nothing is replaced, I'd like to know which files were added so I could basically uninstall it if any problems occur.
Posted on December 23, 2012 12:29PM by Damage Inc.
I'm pretty new to this, but have been able to successfully install all scripts except for this one... and this one is more of a priority for me. I tried installing this multiple times (to GTA IV), and I get no new safe houses. When I push the ` key and bring up running scripts, this one doesn't show up... Any suggestions? This mod looks awesome and I really want it to work.

Thanks
Posted on December 23, 2012 1:37PM by GONADS125
@DamageInc Tell the installer to install the files to your desktop, that will show all of its contents.
Posted on December 24, 2012 12:38AM by JerryKapowitz
@Damage Inc: As it it is sayed in the description, nothing is replaced. However, it doesn't really work. I get the message "Mod installes", but nothing happens.

Where do I have to install the files? Scripts folder or root directory?
Posted on December 24, 2012 8:59AM by DominoCity
ADDITIONAL NOTES (thank you guys for feedback!)

- currently this mod is NOT GTA v1.0.4.0 compatible :( SORRY!

- some people need to start the installer as administrator (Right-click on e.g. "New Safehouses for EFLC.exe" (and choose "Advanced" at the bottom) and select "Run as Administrator")!

Then browse to your GTA ROOT DIR! (e.g. "C:\Program Files (x86)\Rockstar Games\EFLC") and click 'OK'!

- this is a "Aru C++ ScriptHook" (.asi) mod and NOT a "HazardX ScriptHookDotNet" (.cs , .vb , .dll , .net.dll) mod! You CAN'T start it via console (using "`" or "^" key)!

- UNINSTALLING:

EFLC:

Remove "Skorpro SafeHouses - TBOGT.asi", "Skorpro SafeHouses - TLAD.asi", "Skorpro New SafeHouses v1.0 - TBOGT.ini" and "Skorpro New SafeHouses v1.0 - TLAD.ini"!

GTA IV:

Remove "Skorpro SafeHouses - GTA IV.asi" and "Skorpro New SafeHouses v1.0 - GTA IV.ini"!

EFLC & GTA IV:

Remove "..\SkorproParty.mp3"

Remove "..\Movies\Skorpro_TV.bik"!

Then DELETE "..\PC\HTML\www.a-thousand-words.net" and "..\PC\HTML\www.skorpro-new-safehouses.mod" then RENAME "..\PC\HTML\www.a-thousand-words.net - original" to "..\PC\HTML\www.a-thousand-words.net"!

- The installer has the following files:

GTA IV & EFLC:

pc\html\www.a-thousand-words.net (folder)

pc\html\www.a-thousand-words.net - original (folder)

pc\html\www.skorpro-new-safehouses.mod (folder)

movies\Skorpro_TV.bik

SkorproParty.mp3

EFLC only:

Skorpro New SafeHouses v1.0 - TBOGT.ini

Skorpro New SafeHouses v1.0 - TLAD.ini

Skorpro SafeHouses - TBOGT.asi

Skorpro SafeHouses - TLAD.asi

GTA IV only:

Skorpro New SafeHouses v1.0 - GTA IV.ini

Skorpro SafeHouses - GTA IV.asi

Posted on December 26, 2012 8:02PM by Skorpro
I have installed everything it asked me to and it still doesn't work. Please help this looks amazing
Posted on December 30, 2012 2:04PM by Camelot55
Doesn't seem to work. But I guess there's something wrong with my installation, cause this if obviously supposed to work.
Posted on December 30, 2012 3:04PM by Damage Inc.
can you add avideo about installing?
Posted on December 31, 2013 12:40AM by NIMAPD
i will
Posted on January 1, 2013 10:26AM by Joez629
I Download Today
Posted on January 3, 2013 1:00AM by Eddy Alvarez
Can someone make emo character skins
Posted on January 13, 2013 4:34PM by killz268
10/10 from Trashpig
Posted on January 29, 2013 7:02AM by Trashpig
Love this mod man, would it be possible to add a car of your choice on driveways etc where possible? So if you save at a mansion you have a posh car available?
Posted on February 12, 2013 5:01PM by powler
Thanx again to ALL who like my mod :D

@powler

Please visit http://www.gtaforums.com/index.php?showtopic=487035

for my "Parked Cars v1.3 & Save Position v1.08 (GTA 4 & EFLC)"
Posted on February 12, 2013 5:18PM by Skorpro
Oh cool cheers buddy :-) love your work man
Posted on February 12, 2013 5:38PM by powler
Hi guys!

I have created an update for this mod, because some people with GTA IV v1.0.4.0 got big problems...

This update has NO other additions/options! It's for compatibility only!

I'm searching for testers with GTA IV v1.0.4.0 (NOT v1.0.7.0 and NOT EFLC!)

Please visit:

http://www.gtaforums.com/index.php?showtopic=536895

Thanks in advance!

Skorpro
Posted on February 22, 2013 4:00AM by Skorpro
i tried to install this, the website works in game but no safe houses show up, play boy x's doesn't appear so im assuming the rest dont
Posted on March 18, 2013 2:53AM by beaverfeaver12
nvm its working
Posted on March 18, 2013 3:24AM by beaverfeaver12
thx skorpro works i am playing it on eflc thanks a lot
Posted on March 28, 2013 10:22AM by south14
beautfl

Posted on March 29, 2013 4:42AM by nelly brown
I have a problem, your Mod is successfully install, but does not start in the game, I haven't the blips in the map and nothing happens. Yet in the ini file all is activated, and the files Visual c++2010 and NET Framework 4 recommended are installed because I use EPM mod requir the 2 Microsoft files.
Posted on April 8, 2013 12:36PM by nascarien
@nascarien AND @ALL who have the same problem OR GTA IV v1.0.4.0!!!

Please download this update (v1.01)!

Here: http://www.share-online.biz/dl/0RWRT0LMHE68

OR

Here: https://www.hidrive.strato.com/lnk/SInNDc7P

Have fun :)

SKORPRO
Posted on April 9, 2013 11:07PM by Skorpro
thanks for the new update. Now it's OK
Posted on April 14, 2013 1:19PM by nascarien
got it to work after installing visual-studio-2010-express i had all the others but it need this to work Fantastic mod 10/10
Posted on April 21, 2013 4:10PM by carlos70
great but i noticed 1 thing you could maybe change.

The day doesnt pass if you save after 18:00, only 6hours pass,

making you play the day over again.

So when you save a game after 18:00 you should add not only 6hours, but also a day.
Posted on April 29, 2013 4:20PM by DeMatti
Does it work on GTA IV 1.0.3.0?
Posted on May 5, 2013 1:29AM by shubham1611
I downloaded it and it worked fine but when I try to have a private party it crashes the game. I just wanted to try out the mod :P
Posted on May 13, 2013 6:37AM by MisterMedic
working fine on 1.0.1.0 .. the first run it carsh the game and after the 2nd try it work just fine .

Posted on May 18, 2013 3:31PM by Deve
I had some problems installing this mod the first time, but I finally got it to work! Thank you so much, Skorpo!

For those who can't get it to work, try this (I use 1.0.7.0 IV):

Originally, my computer would not let me install Visual C++ 2010 to my computer, so I did the following:

1. Went to my secondary computer and downloaded the exe for Visual C++ 2010

2. Installed it normally to my computer

3. I copied the following from these locations:

-"msvcp100d.dll", "msvcr100_clr0400.dll", and "msvcr100d.dll" from C:/Windows/SysWOW64

-"Visual Studio 2010" folder from "My Documents" folder

-"Microsoft Visual Studio 10.0" from C:/Program Files

-"Microsoft Visual Studio 10.0" from C:/Program Files (x86)

4. I then put these folders on my USB and copied them to the same locations on my other computer, and it worked!

Posted on June 3, 2013 12:51AM by RobertBlox
Can you save cars at Them?
Posted on July 18, 2013 1:35AM by Lost_Warrior
Can you save cars at Them?
Posted on July 19, 2013 6:10PM by Lost_Warrior
Are these safehouses buyable? Or auto unlocked? Could you make them buyable if they aren't? I'd like that.
Posted on July 31, 2013 4:57AM by Virazol
You sir, are based god. Having a life in the Majestic Hotel never felt better!
Posted on August 16, 2013 12:07PM by AntonioSS22
Does these work on 1.0.7.0?????

Posted on August 19, 2013 7:53PM by SuperNiko
@Lost_Warrior

Please use my ParkedCars mod to do this:

http://www.gtaforums.com/index.php?showtopic=487035

@Virazol

No, they are UNLOCKED! (Maybe I will create a new version... but I can't promise that!)

@AntonioSS22 & ALL

THANX for using my mod :)

@SuperNiko

YES! This mod is for GTA v1.0.4.0 - v1.0.7.0 & EFLC v1.1.2.0!

If you got problems, install the UPDATE V1.01!!!!

http://www.gtaforums.com/index.php?showtopic=536895

Thanx & c ya... :)
Posted on August 20, 2013 10:32AM by Skorpro
can you see the interior like in the game like your very first safe house

Posted on August 25, 2013 12:42AM by dodge340
Safehouses are working for me, but when i try to save, while its saving the saving freezes and my game doesent save :(. i love this mod but why wont it let me save?
Posted on August 25, 2013 9:44PM by justinrtt
hardest mod yet to get working. took 3 - 4 hrs. this is wehat i had to do. MAKE BACKUPS

1) installed with auto installer and it came up with the msvcr100d.dll error.

2)i deleted the mod and still got the error.

3)deleted the hole game and restored from backup i just made.

4) NO ERROR YAY. no mod not so yay.

5) i right clicked on the exe installer for the mod and extracted the mod. i then installed it manually.

6) error came back. so now i know the error was from the mod. so i installed visual studio 2010 express. DID NOT FIX ANYTHING... i already had all other things installed and updated.

7) i downloaded the file that was posted on one of many sites and posts about this problem with this mod. they said to put it in the game folder. DONT IT WONT HELP.

8) thanks to Dave the post above and his like here"-"msvcp100d.dll", "msvcr100_clr0400.dll", and "msvcr100d.dll" from C:/Windows/SysWOW64" i copped msvcp100d.dll to syswow64. and it worked.

one thing i can say is its a great mod but i dont think i will spend more then 15 min trying to get any mod working from now on. im still trying to figure out if the time i spent on this one was worth it. @Skorpro you should tell everyone that if it fails to make sure they have all the files installed and tell them how to fix this error "msvcp100d.dll". im still trying to figure out how and why your mod requires so many other programs installed to work.

now one program that someone should make is one that runs next to the game and tells you why it randomly crashes. lol or one you put a list of all mods in and it will tell you all that are not going to work together.
Posted on September 7, 2013 10:59AM by oregonmodding
oh and i also installed the compatibility one the 1.0.1
Posted on September 7, 2013 12:55PM by oregonmodding
@dodge340

You can save at Romans safehouse too.

@justinrtt

I'm sorry, never heard about a problem like yours... Please make sure you're using the original (not modded) player model!

@oregonmodding

I'm sorry if you got trouble during installing my mod!

In fact the version 1.0 made problems with GTA IV v1.0.4.0... (I've used some v1.0.7.0 codes). This was FIXED with v1.01!

The "msvcp100d.dll" error was FIXED with v1.01 too!!! Note: It's NOT a modders fault if people don't update their "MS .NetFramework"!

I got dozens of "asilog.txt" from people who got a "msvcp100d.dll" error and I could see that other C++ ASI mods (NOT only my mod) failed too... I suggested to install the hole MS VC++ to update ALL needed files! This was the simplest way to fix this problem, before v1.01 was released!! But on some systems (Windows7!!!) the mod(s) still failed. The reason was: no correct administration rights! Required files like "msvcp100d.dll" were not updated/installed correctly :(

You see I made two mistakes in v1.0 but they were fixed with v1.01! BUT other errors weren't my fault...

Anyway! Sorry for wasted your time... I nonetheless hope that you like my mod :)

Posted on September 12, 2013 9:20PM by Skorpro
Hey skorpro now with all these safehouses. I like a game being realistic, with all the other mods out there to enhance that.

you should look into making it that we have to purchase the safehouse's first before we can use it to save the same. if its easy to do, if not maybe the creator of Farnsworth's business Mod could tip how to do the purchase code. :D
Posted on September 29, 2013 10:41PM by synthetic_llama
@Skorpro. YOU OBVIOUSLY HAVE A GREAT MOD, TRUE! BUT YOU ALSO NEED TO MAKE "A GREAT VIDEO TUTORIAL" FOR PEOPLE TO FOLLOW EXACTLY HOW TO INSTALL THIS MOD..?!!.

- THIS VIDEO TUTORIAL BY MR.TURTLES ON YOUTUBE IS HORRIBLE, CONFUSING AND FAST. NOBODY UNDERSTANDS IT.

- SKORPRO, YOU CAN MAKE VIDEOS.PLEASE.. MAKE A "BETTER TUTORIAL" FOR YOUR SUBSCRIBERS AND POST IT HERE. THANKS!
Posted on September 30, 2013 9:53AM by ge2gold
:D thank you :D
Posted on October 18, 2013 6:19PM by spike10164
I LİKE ALDERNEY CRACK HOUSE :)
Posted on March 8, 2014 5:17PM by truckerahmet
it says a dll file is missing from my pc .try reinstalling it.
Posted on April 2, 2014 3:30AM by gtagod1234
@ALL

Thanx again :D

@gtagod1234

Make sure you have installed the UPDATES too! Visit GTAForums.com...

LINK:

http://gtaforums.com/topic/536895-new-safehouses-mod-by-skorpro

Posted on April 5, 2014 3:13AM by Skorpro
Sorry, you must be registered and logged in to post a comment. Log in now!