Real Traffic Spawn 1.02

by bonako
Please explain why you're reporting this file:

Cancel
 
Spawn random vehicles in the traffic.

in traffic.cfg can configure the numbers of cars and much others

need a lot of recurses
1gb video ram
3 gb mem ram
Rating:
7.97/10 - 100 votes
Downloads: 62,834
Added: March 12, 2010 2:00PM
Last Downloaded: October 19, 2014 8:07PM
File Size: 396.96 KB
» Author Website

Sorry, you must be registered and logged in to add a video to this file. Log in now!

LOOKS GOOD
Posted on March 12, 2010 3:45PM by rapha1996
spawn cars with ppl inside riding around the city or just cars in parks etc?!
Posted on March 12, 2010 6:55PM by philipe89
spawn arround the city. I test with patch 5 and i get a error when i run gta :/ i think its work only for 1.0.4.0
Posted on March 12, 2010 7:06PM by polodave
tested in 1.0.4.0, don´t like pacht 5 (1.0.0.4)

spawns cars arronud the city
Posted on March 13, 2010 9:08AM by tartexs
yes nice

very nice but it's not new :D ;)

some times if you use some heavy graphic settings your game might crash so just change settings
Posted on March 13, 2010 12:45PM by amd74
i tested and is great..

but i found a bug.. if u can fix it..

in the place of the train its a cable car.. 0.o

and spawns some cars that dont need to be spawn, like airtug, flyus cars..
Posted on March 13, 2010 12:46PM by philipe89
^^haha, theres really a cable car there? XD
Posted on March 13, 2010 2:02PM by LCstuntman
Haha thats pretty funny, yea its best to set the max to 5 or 10 cars, so you dont get flyus cars. haha
Posted on March 13, 2010 2:05PM by hardcorecod6
i dont make te mod. only upload it.

amd74

some times if you use some heavy graphic settings your game might crash so just change settings

the cars models are to big (+2mb) (mods)

original only 500kb...
Posted on March 13, 2010 2:09PM by tartexs
yep.. and i found another bug..

when i thief a spawned car in some meters longer driving it desapears 0.o
Posted on March 13, 2010 2:36PM by philipe89
when scripthookdotnet be compatible with patch 1.0.0.4 (5) this mod will also work
Posted on March 14, 2010 5:53AM by polodave
I am confused, what exactly does this do? does it just give a better diversity of cars in the traffic?
Posted on March 14, 2010 10:38PM by GTR Warrior
yep.. its more usefull for who uses cars modded and get only taxis and police cars in traffic.. ;D

but sometimes crashes here.. ;/
Posted on March 15, 2010 5:01PM by philipe89
I tried to install it, but I think I did it wrong. I dragged both files into the GTA IV folder and when I load the game it is still only taxi's driving around. I don't understand the read me file could someone help me? Do I need ans .asi loader?
Posted on March 16, 2010 6:33PM by GTR Warrior
BEST MOD EVER!

That is not perfect, but it is the best way I've seen to get rid of the "taxi bug". You should work with the guy of "traffic flow" and make a mix of your mod, I'm sure they are complementary.

Please correct the few bug you have.

an other bug: cars are coming from the beach in broker.
Posted on March 18, 2010 6:11AM by Gus84
LOL this thing is too bad for me. First i liked it alot. Then i noticed cars spawning on beach in parks, well that would be ok. Next thing, cars would be disappearing ahead of me in too short distance. They spawn nice for enough, they come close and when they getting away they disappear like about 2 or 3 cars over ahead. AND when i accidentally hijacked one of them it vanished right under my * about 3 seconds after i got in. And that killed it for me. LOL. I tried different combination of spawn distance and cars removing radius, but nothing made difference. They would always vanish unless i did not get close to them first.
Posted on March 20, 2010 4:30PM by tall70
Looks good!
Posted on March 29, 2010 9:14AM by Hypertenzion
does anyone have a fix for when gta a car then it vanishes after few seconds from right underneath you?
Posted on April 14, 2010 4:54PM by wapeddell
Sorry

may it work on previous versions ??

such as 1.0.3.0

if not my u make up one

because many my favorite old mods are only for 1.03

thx a lot
Posted on April 18, 2010 4:11AM by billtaco
hey i fond the newer 1.0.3 version :

http://gta-heroes.ucoz.ru/load/mody_dlja_gta_iv/script_mods_gta_iv/real_traffic_spawn_1_03/10-1-0-105
Posted on May 8, 2010 12:30PM by polodave
That's not a new version. It's exactly the same as 1.02.
Posted on May 17, 2010 11:13AM by Hitomics
I am running version 1.0.4.0 and am having the vehicles randomly disappear underneath me bug - its a great shame as this is the only mod which fixes nothing but taxis spawning the whole time.

I use the following:

GTA IV (version 1.0.4.0 as previously stated)

ENB Series mod (custom config)

Ultimate Vehicle pack v2

Ultimate Textures

Does anyone know how to stop the vehicles randomly vanishing into the warp as we are driving? Any help would be greatly appreciated!!!

Posted on May 28, 2010 2:25PM by hughythomas
This is an awesome mod! However, I too have the issue where if you get into a spawned car and start to drive it just disappears entirely. Fix this issue and we will have an excellent solution to the Taxi curse! We beg you tartexs, PLEASE FIX THIS!, and we will then love you forever :-)
Posted on May 30, 2010 10:19PM by Gamester
Hello people,

how to install the thing please? The readme is unreadable and I'm not sure which files to copy and where. And does this work on EFLC? Thank you very much!
Posted on June 4, 2010 6:38AM by jackkk1
DISAPPEARING CAR ISSUE RESOLVED!!!

Hey guys,

Well, I have been messing around with this mod for several days now and I just finally figured out a way to stop that annoying issue with the cars disappearing randomly when you get in them. All you have to do to fix this is set the value for removing cars around you to a very high number. Don't worry about cars not spawning after changing this value because for some reason the cars still spawn at normal distances around you regardless of what this number is set to. This must just be a bug in the coding of the mod.

For example, I set mine value to the following:

REMOVE_CLOSE_CARS = 9999999

I have been playing for hours now and have not had a single car disappear. I hope this helps everyone who has been having this issue to enjoy this mod as intended :-)
Posted on June 8, 2010 11:29PM by Gamester
Mate - you are a legend.

I can confirm that setting REMOVE_CLOSE_CARS to 9999999 indeed DOES work!

Thank you Gamester you have just made this game playable for me (and no doubt others) again!
Posted on June 9, 2010 4:29AM by hughythomas
definitely gonna try out after next HW upgrade.
Posted on June 10, 2010 3:27AM by Dhatz
Please, how should I install the mod? I can't read the Russian readme. Could you please help me? I have the EFLC 1.1 version.
Posted on June 11, 2010 3:05PM by jackkk1
this mod works only for IV, not for eflc
Posted on June 13, 2010 5:21AM by polodave
will GTA4 versions 1.0.3.0 works well??????
Posted on June 15, 2010 5:45AM by billtaco
Hi,

Can you please tell me where to put all the files ?

Because when put in the main GTA IV folder, the game doesn't start, it's stopping very quickly (I have the last game update).

Thanks a lot for your help
Posted on June 20, 2010 4:36AM by raphpro
please, can anyone tell me in which folder to put the files ?

Thank you
Posted on June 21, 2010 4:35AM by raphpro
Hi Raphpro

Listen man I am running version 1.0.4.0 of GTA IV - this mod does not seem to work with latest version. You will have to reinstall the game and grab either the 1.0.3.0 patch or 1.0.4.0. It's not like the latest patches really added much anyway in my opinion!

Hope this helps!
Posted on June 22, 2010 1:14PM by hughythomas
High hughythomas,

thanks a lot for your reply!

I will reinstall the game then, until v. 1.0.4.0, and will let you know if it works.

The files have to be put into the main GTA V folder?

Thank you again for your help!
Posted on June 22, 2010 2:24PM by raphpro
Hi,

I re-installed until v. 1.0.4 and the car mod. But the spawn isn't really working, as I still have the same cars for each quarter/part of the city.

Where exactly am I supposed to extract these files in the installation directory ?

Thank you
Posted on June 25, 2010 4:01PM by raphpro
how do i get this to work it just keeps crashing i dont know where to put it in the folder. im on version 1.0.7.0 hel cuz i NEED this
Posted on July 12, 2010 5:51AM by xmurrx
Can someone please help? Every time I use the Player Selector mod to browse through characters, at the top left screen it says there is an error in the script. I really want to use both mods. Please reply.
Posted on August 3, 2010 12:56PM by BoomCBS
works quite well which is awesome, just wondering does the mod take its cars to spawn from the cargrp.dat file or what? I only ask as would love to have my added cars spawn as well.
Posted on August 23, 2010 1:26AM by GTA3Freak-2001
also with default settings this causes some pop-ups with buildings and lods in the distance, this is with a 1gb 5770 and only a handful of replaced vehicles so be warned!
Posted on August 23, 2010 10:25PM by GTA3Freak-2001
Hello!

CAN SOMEONE PLEASE HELP TO WHERE DO I NEED TO PUT THIS FILES?? I PUT scripthook, trafficfix.net, traffic, scripthookdotnet files into the main gta folder where is the exe file but this don't work for me! CAN SOMEONE HELP ME HOW CAN I DO THIS TO WORK?

I use 1.0.4.0 patch but this dont work
Posted on August 24, 2010 7:20AM by adamo171
Hello!

CAN SOMEONE PLEASE HELP TO WHERE DO I NEED TO PUT THIS FILES?? I PUT scripthook, trafficfix.net, traffic, scripthookdotnet files into the main gta folder where is the exe file but this don't work for me! CAN SOMEONE HELP ME HOW CAN I DO THIS TO WORK?

I use 1.0.4.0 patch but this dont work
Posted on August 24, 2010 7:29AM by adamo171
Hi adamo!

You have to put the two scripthook files into the main folder, and the whole scripts folder there to. So there will be in the main gta4 folder the scripts foldet with the cfg and the second file, and outside the scripts folder in the gta 4 main folder the two scriphook files.
Posted on August 29, 2010 3:13AM by solowingpixy66
And now everyone!

I can use this mod only if I have asi loader with the dsound.dll. BUT I have the same problem with disappearing, and if I change in the cfg that number to 9999999, the cars just DONT SPAWN. That i: number is growing bigger, spawn: 0 ZERO, NOTHING!!!! Please help. Thank you!

I have GTA IV 1.0.3.0
Posted on August 29, 2010 3:17AM by solowingpixy66
Solowingpixy66!

Thank you very much your help for me!:)
Posted on August 29, 2010 12:57PM by adamo171
And it works well for you?
Posted on August 29, 2010 1:00PM by solowingpixy66
yes, it's works now perfectly for me:)
Posted on August 30, 2010 5:43AM by adamo171
I have the same problem than solowingpixy66
Posted on September 4, 2010 3:26PM by joji360
This mod is the best traffic mod ever man!!! BUT CAN YOU EDIT THE NET FILE AND REMOVE THE "REMOVE CLOSE CARS" DETAIL! IT WOULD BE MUCH BETTER WITHOUT IT CAUSE ITS GAY HOW CARS DISAPPEAR UNDERNEATH YOU.
Posted on September 7, 2010 7:26PM by SPARTAN 0659
Awesome mod but doesn't seem to work with Simple native trainer :(
Posted on September 26, 2010 2:30PM by Mickr4
Hi!

I have EFLC. I knew about this mod doesn't work with eflc, but maybe anyone know how can i use this mod with eflc? I know that this traffic problem can win Vicheles editor, but with it the game begin to be slowly and i dont want it.

Sorry i bad speak English, i dont finnish to study it. I from Russia.

For peopes who can speak Russian

У меня ЕФЛС. Кто нибудь знает как я могу запустить этот мод на ней( у меня 1.1.2.0). Я знаю про Vichels editor, но комп начинает тупить с ним. Даже не комп а игра.
Posted on December 13, 2010 11:20AM by Nikita2604
*...but maybe anyone knowS how can i...

*I'M from Russia
Posted on December 14, 2010 10:50AM by Nikita2604
can someone help... i can't read the readme :S
Posted on December 24, 2010 12:29PM by Gijs571
hey di#k head who created the mod if you only speak Russian then why dont you go to google and Translate it to English, that would help a lot of people out.
Posted on December 27, 2010 9:08PM by HonoredPimP
So anyone can't help me with my problem? HonoredPimP, Google Translates from russian to english bad like from english to Russian.
Posted on December 29, 2010 4:58AM by Nikita2604
Best anti-taxi fix. It's impressive, really. It just doesn't get rid of the cabs, it spawns different cars in the road and not all the same one. Excellent job! Too bad it doesn't work with LCPDFR and probably other modifications.
Posted on December 31, 2010 8:10PM by Cop_21
* AWSOME! YOUR'E MY HERO! THESE OTHER PEOPLE SHOULD ALSO GIVE U 10/10 FOR IT! THANKS...X1000000

Posted on January 9, 2011 10:23AM by newhope8
PLEASE HELP! Oh dear...i got to corragous with my mods and i tried installing this one. But i put things in the wrong folders and nothing worked and then GTA wouldnt even open! So, i uninstalled the game and lcpdfr (exept my save game files) and tried to restart and now nothing happens :( When i try to start gta now a black box immediately appears and says GTA has stopped working. Any suggestions, please message me or email me chrsmats@aol.com Thanks!!! (im sure its an easy fix, im just computer retarded)
Posted on January 13, 2011 8:19AM by chrsmats
Absolutely AMAZING mod! I was reading the horror stories trying to get this to load, I have STEAM version 1.0.7.0 and THIS WILL ABSOLUTELY WORK!!! I watched from another computer inside the GTAIV folder, my Asilog file say it loaded the correct Asi and I see in the upper left corner (which I don't really wanna see) all the cars spawning. Amazing!

This took me 2 hours to piece together! I copied over a new binkw32.dll file, copied in a new dsound.dll from Alexander Blade (1.28.09 file), copied the scripts folder into the GTAIV folder, made the change in cfg file from 35 to 999999, copied NEW scripthook files by searching google for "Scripthookdotnet 1.0.7.0", installed newest C++ Visual pack. Ran LaunchGTAIV as Administrator and tada.

Hope this is helpful to anyone having the same trouble I was having!!!

Btw, 10/10!
Posted on January 19, 2011 8:20PM by Wreckless Hype
@Wreckless Hype

I see the text in the upper left corner to, but the mod does not work in 1.0.7.0 because vehicles in the text don't spawn on the the roads.
Posted on February 2, 2011 1:13PM by polodave
it works on 1.0.3.0 , 1.0.4.0  and 1.0.6.0 only.
Posted on February 5, 2011 5:37AM by polodave
Its working with newest EFLC too. You just have to install the newest script tools also.
Posted on March 14, 2011 6:39AM by LocutusH
wreckless hype: thanks!!!
Posted on July 12, 2011 10:46AM by rakakak
Hey man, to have a problem with this mod, when I steal a car, he disappears after a few seconds! and some other cars in the traffic disappear!

If you could help me send me an Email> leitao_85@hotmail.com
Posted on July 23, 2011 2:21AM by leitao85
i created an account just to comment on this LOL

this is the best mod !! i thot i was the only one pissed off with the spawn distance but maybe i still am the only one but not anymore. Your spawn distance option makes the game a million times more realistic only bad thing is the textures started loading kinda slow but i can live with that
Posted on July 23, 2011 3:18AM by boobietrap1000
Ok, one MAJOR problem. Cable cars spawn as the subway, and my game crashes after like 40 mins of play, and they spawn in airport, the sky (wtf) etc. Eventually, there are too many of them, and the game crashes. (the spawned cars won't disappear)
Posted on July 23, 2011 2:33PM by MiG95
instead of putting 99999 in the cfg file put 900 or 1000 i guess

hope this helped
Posted on July 24, 2011 5:39AM by boobietrap1000
It works in 1.0.7.0 you need to work around the issues. I used this and real traffic + real traffic spawn 1.02 + ultimate vehicle v6. I used the trainer to disable cars and turned down the vehicle density in hopes that the spawner would kick in, then I set vehicle density to 100 and re-enabled cars. Also, this is important and probably the main reason it all worked:

paste this into the traffic.cfg for real traffic or just replace the numbers.

// how many cars to spawn

MAX_CARS_SPAWNED = 10

// on every i-th iteration additional cars are spawned (larger values means faster spawning)

ADDITIONAL_SPAWN_CYCLE = 2

for some reason, magic, this with the vehicle density set to 100 got the traffic working and tons of it. The 10 and 2 are just to keep the textures from glitching. You may need to adjust the numbers to you system. I will keep fiddling with it to see if I can nail down an exact formula, or just write a new traffic control system.

core i7 920 stock

2GB gtx 285

6GB dominator

veloci-raptor HDD
Posted on August 2, 2011 9:59PM by MegaGBeez
When i instal this my GTA IV wont start. If i delete it, it will. I patched it to version 1.0.7.0. I really want to try this method from boobietrap 1000, but can't. PLS SOMEONE HELP ME:P( THANKS)
Posted on August 8, 2011 10:57AM by dendaas20
Can you get someone to update it to 1.0.7.0
Posted on October 30, 2011 2:06PM by gtaivfordenmark
i tryed alot off car mods for gta4 on pc every mode come whit error where i need to look for my version of gta4 because i cant find a compatible mode patch for cool cars i just want to drive around the city because i finished the game and its getting boring whit this cars...
Posted on October 31, 2011 1:02PM by Nr1Norby94
using 1.0.7 patch with this all works ok.However after half an hr or more the game crashes probably due to so many cars spawning.So is there any way to stop the cars spawning automatically after a certain time i currently have the following

SPAWN_INTERVAL = 10000000000

But still the cars keep coming ends up so many cars the game exits to desktop.im sure its this which is causing the game to crash

Desktop Specs

I7 920 @2.67 GHTZ

18 GB DDR 3 RAM

Windows 7 Professional 64 bit

2 x 1tb Harddisks

ATI RADEON HD 6900 SERIES

Posted on October 31, 2011 2:13PM by mathall1
Hi guys! i really need your help!

I got tbogt version 1.1.2.0, with a lot of car mods

no ENB or something like that..just car mods.

i had the problem that there where only taxis driving around but then i got this mod and it helped me, kinda..

there is now taxis,cops and just like 2-4 other types of cars driving around on the whole map.

i tried to change some numbers in the DAT file but it didnt help :(

do you have any suggestions?
Posted on December 1, 2011 11:11PM by swedish_ninja
Looks great, but the spawned car lost :O
Posted on January 2, 2012 8:17AM by blink04
i cant understand the realTrafficSpawn_readme.txt please comment the readme in english..

tnx i need it ASAP
Posted on February 18, 2012 10:11AM by Izzykit123
use google translate for converting the readme
Posted on March 2, 2012 6:47PM by ROGxRAMPAGE
Great! Love it. One problem though... When I nick a car it dissapears after a couple of seconds... Any ways to fix this??
Posted on March 12, 2012 7:26AM by AshleyCopper
Есть два замечания: 1. Машины выезжают из парков, и других мест непригодных для езды; 2. За рулём авто специального предназначения (Скорая, Пожарная, Инкасаторная, Мусоровозы и прочих) сидят обычные люди, а не спец службы.

Пожалуйста исправьте эти два замечания!!!!!!!!!!
Posted on April 5, 2012 8:59AM by BOPOHua
Is not this an English forum?
Posted on May 18, 2012 5:59AM by AureusButeo
Well this is kinda of akward. Actually I made this mode years ago when I was bored. I also released it with an english readme, stating that it was UNFINISHED WORK ;). I never continued it because I sadly lost all my progress when my HDD crashed. If you want my original verison with the english readme, get it here:

http://rapidshare.com/files/357514606/trafficFixv01.zip
Posted on June 22, 2012 1:52AM by ech3lon
hey,why i try this mods,and work perfecly but i use native trainer is not working or i want get car in native trainer but unload please help me

Thanks
Posted on July 19, 2012 11:24PM by Handyfisher
can someone help me i have gta4 and i am sick of all the old cars how do i download more car plz help!!!!!!!!!!!

Posted on July 28, 2012 5:20PM by dbneeds---mods3
1/10
Posted on November 25, 2012 2:41PM by vagenrider
This works, but it's just too random with spawning cars.

First of all, it spawns EVERYTHING, so also the less common vehicles such as the SWAT-trucks, and sometimes they have regular pedestrians in them. Then also vehicles such as the FlyUS-ones, that usually shouldn't be in any area but around the Airport. Why aren't these vehicles excluded?

On top of that, it also overrides this sort of "traffic control"-mod (not THE Traffic Control System) which regulates how many vehicles and pedestrians there are going around and at what times. So while there shouldn't be so many vehicles at night for instance, this mod just ignores that and still spawns vechiles all over the place.

Besides these feature-issues, it also brings a LOT of loading lag.

So it does what it says, it spawns traffic, but it's completely unregulated.

Also, someone should finally get on this (after nearly 5 years) and make something that actually does traffic right. Rockstar better have MASSIVE improvements in store for 5, in both features and performance.
Posted on January 10, 2013 3:54AM by Damage Inc.
I did the tweaks mentioned and it does load; however, it only shows 5 different cars on the road at any given time. It always loads all three taxi types, and then adds 2 more random cars. So, the 2 cars are cycling through, but not the taxis. I'll stick with Chikamru Real Traffic
Posted on January 11, 2013 11:45AM by Trashpig
I did the tweaks mentioned and it does load; however, it only shows 5 different cars on the road at any given time. It always loads all three taxi types, and then adds 2 more random cars. So, the 2 cars are cycling through, but not the taxis. I'll stick with Chikamru Real Traffic
Posted on January 11, 2013 6:05PM by Trashpig
Running 1.0.3 and this is the only one that has worked I tried trafficspawn, trafficload, adn eveyr other one out there and this is the only one that works make sure to hide the text in the ocnfig file to false so you dont have annoying white text in top left and change remove close cars to 999 to get rid of disappearing textures or cars.
Posted on February 26, 2013 11:36PM by Jalenxt
does this work for 1.0.7.0 or just 1.0.4.0?
Posted on June 7, 2013 9:03PM by OpTiK Bellic
Learn to speak English.

Rated: 1/10
Posted on August 1, 2014 5:33PM by CriminalKillaz
Sorry, you must be registered and logged in to post a comment. Log in now!